HDU2602 Bone Collector

Posted by Zexin Zhang on November 1, 2017

HDU2602 Bone Collector

Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.


Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).


Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

#include <cstdio>

#include <cmath>

#include <algorithm>

#include <cstring>

using namespace std;
int dp[1001];
int value[1001];
int cost[1001];
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		memset(dp,0,sizeof(dp));
		memset(value,0,sizeof(value));
		memset(cost,0,sizeof(cost));
		int n,volume;
		scanf("%d%d",&n,&volume);
		for(int i=1;i<=n;i++){
			scanf("%d",&value[i]);
		}
		for(int i=1;i<=n;i++){
			scanf("%d",&cost[i]);
		}
		for(int i=1;i<=n;i++)
			for(int j=volume;j>=cost[i];j--){
					dp[j]=max(dp[j-cost[i]]+value[i],dp[j]);
					//printf("dp[%d]=%d\n",j,dp[j]);
          
			}

	    printf("%d\n",dp[volume]);

	}
	return 0;
}